View on GitHub


Benchmarking framework for data grids and distributed caches

Coherence plugin

Note: This document reffers to application/dependency provided by a 3rd party, the details of which can change at any time in any way, it is therefore not inconcieveable that this document not up to date at some point.

Due to licensing constraints we are not able to provide Oracle Coherence dependency for Coherence plugin and anyone wishing to use it has to download and add it himself. There are two Coherence plugins, for version 3.7.1 and 12.1.2, latter depends on the former so the dependencies have to de satisfied for both is you want the latter.

Both versions are downloadable from OTN upon registration and acceptance of Terms of use.

Version 3.7.1

This dependency is available in a compressed file, specifically as coherence/lib/coherence.jar file, copy into maven repository folder as repository/com/oracle/coherence/coherence/3.7.1/coherence-3.7.1.jar.

Version 12.1.2

This dependency is sadly available only as part of the installation, you will have to install stand-alone version and then pick up the file from installation folder coherence/lib/coherence.jar and copy it into maven repository as repository/com/oracle/coherence/coherence/12.1.2/coherence-12.1.2.jar.

If both operations went smoothly Coherence plugin should now be buildable, run the usual maven build with -Dcoherence parameter.